由浅入深玩转华为WLAN—20 漫游系列(7)不同AC之间二层漫游【二层上线+直连式+直接转发模式】_网络之路Blog的博客-程序员ITS301_华为 ap ac 二层上线

技术标签: 由浅入深玩转华为WLAN  

说明

之前介绍过在AC间漫游的新概念以及一些处理过程,对比AC内漫游相对从配置角度来说不是非常大,只是转发的过程有点小变化,这个可以参考之前介绍的转发过程即可。

二层漫游的数据包转发过程(该图中直接转发与隧道转发方式没差别)

wireless

漫游前数据包的走向
1、STA发送数据给HAP
2、HAP收到数据报文后,发送给HAC(如果是旁挂模式的处理方式,则不太一样,在隧道模式下会转发给HAC,而直接转发方式下,直接由网关交换机直接处理业务报文交给上层设备)
3、HAC收到以后,直接把业务报文送给上层网络

 

漫游后数据包的走向
1、STA发送数据给FAP
2、FAP收到数据报文后,发送给HAC(如果是旁挂模式处理方式如上)
3、FAC收到以后,直接把业务报文送给上层网络。(这里其实还是通过隧道发送给HAC,由HAC转发个上层网络,具体的分析可以看后面的配置部分)

拓扑介绍

wireless

这里我就直接用华为给的拓扑来做介绍了,主要是ENSP目前还是V2R3版本,R5的目前还没有,手上也没有R5版本的AC,所以只能讲解下命令,其实配置跟R3与AC内的区别不是很大,只是多了几个步骤。

实际拓扑建议

wireless

实际工作中,建议肯定需要更多的冗余性,核心之间可以通过多条链路做捆绑,然后起VRRP给下面的用户提供网关,而且也可以避免AC单连交换机的时候,该交换机出现故障,导致AC无法提供业务。

说明:这里还是以官方给的拓扑做介绍,ENSP目前无法支持AC间漫游,所以这里无法演示。

配置的讲解,AP上线以及WLAN业务与R3并无区别,所以这里不做过多介绍,具体可以参考之前的AC内漫游,都有详细讲解。

Switch_1配置

[Huawei-SW1] vlan batch 100 101
[Huawei-SW1] interface gigabitethernet 0/0/1
[Huawei-SW1-GigabitEthernet0/0/1] port link-type trunk
[Huawei-SW1-GigabitEthernet0/0/1] port trunk pvid vlan 100
[Huawei-SW1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
[Huawei-SW1-GigabitEthernet0/0/1] quit
[Huawei-SW1] interface gigabitethernet 0/0/2
[Huawei-SW1-GigabitEthernet0/0/2] port link-type trunk
[Huawei-SW1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
[Huawei-SW1-GigabitEthernet0/0/2] quit

Switch_2配置

[Huawei-SW2] vlan batch 100 101
[Huawei-SW2] interface gigabitethernet 0/0/1
[Huawei-SW2-GigabitEthernet0/0/1] port link-type trunk
[Huawei-SW2-GigabitEthernet0/0/1] port trunk pvid vlan 100
[Huawei-SW2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
[Huawei-SW2-GigabitEthernet0/0/1] quit
[Huawei-SW2] interface gigabitethernet 0/0/2
[Huawei-SW2-GigabitEthernet0/0/2] port link-type trunk
[Huawei-SW2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
[Huawei-SW2-GigabitEthernet0/0/2] quit

AC-1的配置(只包含AP上线以及WLAN业务配置)

[Huawei-AC_1] dhcp enable
[Huawei-AC_1] vlan batch 100 101
[Huawei-AC_1] interface gigabitethernet 0/0/1
[Huawei-AC_1-GigabitEthernet0/0/1] port link-type trunk
[Huawei-AC_1-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
[Huawei-AC_1-GigabitEthernet0/0/1] quit

 

[Huawei-AC_1] interface gigabitethernet 0/0/2
[Huawei-AC_1-GigabitEthernet0/0/2] port link-type trunk
[Huawei-AC_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
[Huawei-AC_1-GigabitEthernet0/0/2] quit

[Huawei-AC_1] interface vlanif 100
[Huawei-AC_1-vlanif100] ip address 192.168.100.1 255.255.255.0
[Huawei-AC_1-vlanif100] dhcp select interface
[Huawei-AC_1-vlanif100] dhcp server excluded-ip-address 192.168.100.2
[Huawei-AC_1-vlanif100] quit

[Huawei-AC_1] interface vlanif 101
[Huawei-AC_1-vlanif101] ip address 192.168.101.1 255.255.255.0
[Huawei-AC_1-vlanif101] dhcp select interface
[Huawei-AC_1-vlanif101] quit

[Huawei-AC_1] interface wlan-ess 1
[Huawei-AC_1-Wlan-Ess1] port hybrid pvid vlan 101
[Huawei-AC_1-Wlan-Ess1] port hybrid untagged vlan 101

[Huawei-AC_1] wlan
[Huawei-AC_1-wlan-view] wlan ac source interface vlanif 100
[Huawei-AC_1-wlan-view] ap id 1 type-id 19 mac 60de-4476-e360
[Huawei-AC_1-wlan-view] wmm-profile name wmm id 1
[Huawei-AC_1-wlan-wmm-prof-wmm] quit
[Huawei-AC_1-wlan-view] radio-profile name radio id 1
[Huawei-AC_1-wlan-radio-prof-radio] wmm-profile name wmm
[Huawei-AC_1-wlan-radio-prof-radio] quit
[Huawei-AC_1-wlan-view] security-profile name security id 1
[Huawei-AC_1-wlan-sec-prof-security] quit
[Huawei-AC_1-wlan-view] traffic-profile name traffic id 1
[Huawei-AC_1-wlan-traffic-prof-traffic] quit
[Huawei-AC_1-wlan-view] service-set name huawei1 id 1
[Huawei-AC_1-wlan-service-set-huawei1] ssid huawei1
[Huawei-AC_1-wlan-service-set-huawei1] wlan-ess 1
[Huawei-AC_1-wlan-service-set-huawei1] security-profile name security
[Huawei-AC_1-wlan-service-set-huawei1] traffic-profile name traffic
[Huawei-AC_1-wlan-service-set-huawei1] service-vlan 101
[Huawei-AC_1-wlan-service-set-huawei1] vlan-mobility-group 101 (可选)
[Huawei-AC_1-wlan-service-set-huawei1] quit

AC-2的配置(只包含AP上线以及WLAN业务配置)

[Huawei-AC_2] vlan batch 100 101
[Huawei-AC_2] interface gigabitethernet 0/0/1
[Huawei-AC_2-GigabitEthernet0/0/1] port link-type trunk
[Huawei-AC_2-GigabitEthernet0/0/1] port trunk allow-pass vlan 100 101
[Huawei-AC_2-GigabitEthernet0/0/1] quit

 

[Huawei-AC_2] interface gigabitethernet 0/0/2
[Huawei-AC_2-GigabitEthernet0/0/2] port link-type trunk
[Huawei-AC_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100 101
[Huawei-AC_2-GigabitEthernet0/0/2] quit

[Huawei-AC_2] interface vlanif 100
[Huawei-AC_2-vlanif100] ip address 192.168.100.2 255.255.255.0

[Huawei-AC_2] interface wlan-ess 1
[Huawei-AC_2-Wlan-Ess1] port hybrid pvid vlan 101
[Huawei-AC_2-Wlan-Ess1] port hybrid untagged vlan 101

[Huawei-AC_2] wlan
[Huawei-AC_2-wlan-view] wlan ac source interface vlanif 100
[Huawei-AC_2-wlan-view] ap id 1 type-id 19 mac 60de-4476-e360
[Huawei-AC_2-wlan-view] wmm-profile name wmm id 1
[Huawei-AC_2-wlan-wmm-prof-wmm] quit
[Huawei-AC_2-wlan-view] radio-profile name radio id 1
[Huawei-AC_2-wlan-radio-prof-radio] wmm-profile name wmm
[Huawei-AC_2-wlan-radio-prof-radio] quit
[Huawei-AC_2-wlan-view] security-profile name security id 1
[Huawei-AC_2-wlan-sec-prof-security] quit
[Huawei-AC_2-wlan-view] traffic-profile name traffic id 1
[Huawei-AC_2-wlan-traffic-prof-traffic] quit
[Huawei-AC_2-wlan-view] service-set name huawei1 id 1
[Huawei-AC_2-wlan-service-set-huawei1] ssid huawei1
[Huawei-AC_2-wlan-service-set-huawei1] wlan-ess 1
[Huawei-AC_2-wlan-service-set-huawei1] security-profile name security
[Huawei-AC_2-wlan-service-set-huawei1] traffic-profile name traffic
[Huawei-AC_2-wlan-service-set-huawei1] service-vlan 101
[Huawei-AC_2-wlan-service-set-huawei1] vlan-mobility-group 101 (可选)
[Huawei-AC_2-wlan-service-set-huawei1] quit

漫游功能相关配置

[AC_1] master-controller enable
[AC_1] master controller
[AC_1-master-controller] ac id 1 ip 192.168.100.1
[AC_1-master-controller] ac id 2 ip 192.168.100.2
[AC_1-master-controller] mobility-group name mobility
[AC_1-mc-mg-mobility] member ac id 1
[AC_1-mc-mg-mobility] member ac id 2
说明:AC_1的配置,它作为master controller,然后在controller里面定义了漫游组,属于同一个漫游组的AC之间是可以漫游的。

 

[AC_2-wlan-view] master-controller ip 192.168.100.1
而AC_2的配置比较简单,只需要指定controller在哪即可,漫游组信息由master告诉其他AC成员。

下发业务给AP

[Huawei-AC_1] wlan
[Huawei-AC_1-wlan-view] ap 1 radio 0
[Huawei-AC_1-wlan-radio-1/0] radio-profile name radio
[Huawei-AC_1-wlan-radio-1/0] service-set name huawei1
[Huawei-AC_1-wlan-radio-1/0] quit
[Huawei-AC_1-wlan-view] commit ap 1
Warning: Committing configuration may cause service interruption,continue?[Y/N]y

 

[Huawei-AC_2] wlan
[Huawei-AC_2-wlan-view] ap 1 radio 0
[Huawei-AC_2-wlan-radio-1/0] radio-profile name radio
[Huawei-AC_2-wlan-radio-1/0] service-set name huawei1
[Huawei-AC_2-wlan-radio-1/0] quit
[Huawei-AC_2-wlan-view] commit ap 1
Warning: Committing configuration may cause service interruption,continue?[Y/N]y

测试

这里把一个客户端连接到AP_1上后,可以通过命令查看

[Huawei-AC_1-wlan-view] display station assoc-info all
——————————————————————————
STA MAC AP ID RADIO ID SS ID SSID
——————————————————————————
0025-86aa-0d1c 1 0 1 huawei1
——————————————————————————
Total stations: 1
目前该客户端关联上来了,当把客户端从AP_1移动到AP_2的范围内

[Huawei-AC_2-wlan-view] display station assoc-info all
——————————————————————————
STA MAC AP ID RADIO ID SS ID SSID
——————————————————————————
0025-86aa-0d1c 1 0 1 huawei1
——————————————————————————
Total stations: 1

这时候AP_2上面已经有关于客户端的信息了。

[Huawei-AC_2-wlan-view] display station roam-track sta 0025-86aa-0d1c
Access SSID:huawei1 Rx/Tx:Rx-Rate/Tx-Rate Mbps
——————————————————————————
L2/L3 AC IP
AP/Radio BSSID TIME In Rx/Tx RSSI Out Rx/Tx RSSI
——————————————————————————
— 192.168.100.1
1/0 60de-4476-e360 2014/01/03 11:46:12 61/61 -51 46/13 -48
L2 192.168.100.2
1/0 dcd2-fc04-b500 2014/01/03 11:48:17 61/61 -58 -/- –
——————————————————————————
Number of roam track: 1

在AC上面通过漫游命令查看该MAC地址,可以看到从100.1的AC漫游到了100.2的AC上面,L2表示二层漫游

二层漫游的数据包转发过程(该图中直接转发与隧道转发方式没差别)

wireless

漫游前数据包的走向
4、STA发送数据给HAP
5、HAP收到数据报文后,发送给HAC(如果是旁挂模式的处理方式,则不太一样,在隧道模式下会转发给HAC,而直接转发方式下,直接由网关交换机直接处理业务报文交给上层设备)
6、HAC收到以后,直接把业务报文送给上层网络

 

漫游后数据包的走向
4、STA发送数据给FAP
5、FAP收到数据报文后,发送给HAC(如果是旁挂模式处理方式如上)
6、FAC收到以后,直接把业务报文送给上层网络。(这里其实还是通过隧道发送给HAC,由HAC转发个上层网络,具体的分析可以看后面的配置部分)
FAC收到以后,为什么是通过隧道发给HAC呢,可以看到配置里面,其实网关都是在AC_1上面的,当客户端从AP_1漫游到AP_2后,地址网关都没有变化,那么当数据包发送给AC_2的时候,它并没有VLAN 101的VLANIF接口,不能直接转发给上层网络,而是转发给HAC,由HAC来转发数据包。

当然这个模型只是讲解了下二层AC间漫游如何配置,实际环境中并不推荐这样的拓扑,因为可以看到,如果AC_2与AP_2上面也有无线业务需要关联,那么AC_2必须起VLANIF接口与DHCP,而且与AC_1在的业务VLAN是同一个VLAN与网段,那么分配的DHCP只能 5/5的分配,也就是AC_1分配,192.168.101.1~128,而AC_2分配192.168.101.19~254,这样的话不造成冲突,如果无线客户端比较多的话,那么明显地址是不够用的,需要多加VLAN,或者使用超网,这样的话对于部署网络加大了难度。而且冗余性也不够。

wireless

如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weixin_46948473/article/details/114631769

智能推荐

聊聊Elasticsearch的RunOnce_chuoguo3754的博客-程序员ITS301

序本文主要研究一下Elasticsearch的RunOnceRunOnceelasticsearch-7.0.1/server/src/main/java/org/elasticsearch/common/util/concurrent/RunOnce.javapublic class...

MySQL中实用函数及查询技巧_intomylife的博客-程序员ITS301

函数一:CONCAT使用场景:查询时把多个字段拼接成一个字符串 例 子:select concat('id:',id,',name:',name) from student 解 析:需要连接的字段用逗号分隔开来,自定义的拼接符号使用单引号包裹,也使用逗号分隔 注 意:这个函数需要注意的是,如果有一列值为空,那么这一列拼接的结果都会为null,为了避免这...

Unity MMO游戏架构设计之角色设计一_海洋_的博客-程序员ITS301_unity设计过程中,模型充当了什么样的角色

笔者介绍:姜雪伟,IT公司技术合伙人,IT高级讲师,CSDN社区专家,特邀编辑,畅销书作者,国家专利发明人;已出版书籍:《手把手教你架构3D游戏引擎》电子工业出版社和《Unity3D实战核心技术详解》电子工业出版社等。CSDN视频网址:http://edu.csdn.net/lecturer/144 网上很多人问我关于MMO大型网络游戏中的架构设计,本篇博客主要是给读者介绍关于角色的设计,游戏中都

计算机网络上不去的原因是什么,路由器有信号却上不了网是什么原因?_MHJCR的博客-程序员ITS301

路由器(Router),是连接因特网中各局域网、广域网的设备,它会根据信道的情况自动选择和设定路由,以最佳路径,按前后顺序发送信号。那么路由器有信号却上不了网是什么原因?为什么路由器有信号却上不了网?路由器有wifi信号,但是连接wifi信号后不能上网。这是因为路由器与宽带运营商的服务器之间连接不成功,至于原因主要有3个方面:一、宽带故障首先,我们需要检查下宽带是否出现了故障;因为如果宽带本身出现...

Visual Studio – 借助远程Linux服务器环境在Visual Studio中编写和远程调试Linux C++程序_HW140701的博客-程序员ITS301_visual studio远程调试linux

1 环境准备1.1 安装使用C++的Linux开发的工具集首先需要在Visual Studio Installer中安装使用C++的linux开发的工具集等待使用C++的Linux开发的工具集安装完成,并重启Visual Studio。1.2 准备可远程的Linux服务器以及在远程服务器安装远程调试环境1.2.1 明确Linux服务器的cpu架构首先需要清楚该服务器的cpu是x_86、x_64还是arm,这在之后的Visual Studio中需要选择编译平台。1.2.2 配置远程Linux服

HTTP cookies_zhouguoqionghai的博客-程序员ITS301_cookie http

http cookies 分为 session cookies 和 persistent cookies 两种。session cookies:服务器在应答头中发送给客户端一个设置特定字段 Set-Cookie 的数据(各种不同的字段有好几百种),客户端在请求头中回应给服务器端一个 Cookie 数据。效果大概如下:HTTP response from web server:

随便推点

2019年Android中高级工程师部分面试题_generallizhong的博客-程序员ITS301

一、中级面试题1、Activity生命周期2、onStart()与onResume()有什么区别?onStart()是activity界面被显示出来的时候执行的,但不能与它交互;onResume()是当该activity与用户能进行交互时被执行,用户可以获得activity的焦点,能够与用户交互。3、Activity启动流程startActivity最终都会调用start...

Hi3516EV200 编译环境配置及交叉编译软件包_SimonRiley_的博客-程序员ITS301

原文地址:Hi3516EV200 编译环境配置及交叉编译软件包 - WindSpiritIT基础信息OS: Ubuntu 16.04 xenialSDK 版本: Hi3516EV200R001C01SPC012 - Hi3516EV200_SDK_V1.0.1.1SDK 包路径:Hi3516EV200R001C01SPC012\01.software\board\Hi3516EV200_SDK_V1.0.1.2.tgz开发板地址:192.168.1.54开发板 MAC:7C:A7:B0:F6:E

使用vue+iview实现上传文件及常用的下载文件的方法_weixin_30896511的博客-程序员ITS301

首先说明一下,我们这次主要用的还是iview的upload上传组件,下面直接上代码<Upload ref="upload" multiple='true' //是否支持多文件上传 :show-upload-list="true" //显示上传的文件 :before-uplo...

传统数据库逐渐“难适应”,云原生数据库脱颖而出_cdtaogang的博客-程序员ITS301_云原生数据库技术挑战

数据库一直是应用开发中非常重要的一部分。从MySQL到亚马逊的RDS(关系型数据库服务,Relational Database Service),业界有很多数据库系统供开发者存储、查询和管理数据。随着海量计算的持续发展,给传统数据库带来了不少挑战,而云原生数据库却可以应对这些挑战。...

php session set save,php session session_set_save_handler 机制_weixin_39863008的博客-程序员ITS301

php自身带功能,将session的数据从之前的files 改变到其他任何地方。比如mysql redis等等,方便你分布式的集群应用。看一下原理/***Session open (called by session_start( ))*Session close (called at page end)*Session read (called after session_start( ...

367-93-1,Isopropyl 1-Thio-β-D-galactopyranoside,异丙基-beta-D-硫代半乳糖吡喃糖苷_陕西新研博美的博客-程序员ITS301

中文名称:异丙基-beta-D-硫代半乳糖吡喃糖苷英文名称:Isopropyl 1-Thio-β-D-galactopyranosideCAS:367-93-1分子式:C9H18O5S分子量:238.298结构式:密度:1.37熔点:105℃沸点:438.4 oC at 760 mmHg折射率:1.577闪光点:219 oCPSA:115.45000logP:-1.07210外观:白色粉末溶解性:易溶于水、甲醇、乙醇,可溶于丙酮、氯仿,不溶于乙醚。

推荐文章

热门文章

相关标签