静态路由的配置,实现全网可达_登陆路由器,配置loopback等接口的ip地址,设置静态路由,实现全网互联互通。-程序员宅基地

技术标签: 网络  网络安全  

静态路由的配置

(1)配置静态路由常用命令

配置路由接口IP与掩码:ip address IP地址 子网掩码

如:ip address 192.168.1.1 255.255.255.0

配置静态路由:ip route 目标网络 目标网络子网掩码 下一路由器接口ip地址/送出口

(注:此处的目标网络是指一个地址段,不是一个IP地址)

如:ip route 192.168.2.0 255.255.255.0 192.168.3.1(g0/0/0)

查看路由表:display ip routing-table

(2)静态路由配置实验如下:

配置静态路由,使各PC能够正常通信,查看路由表进行分析,进行配置,最后再次测试,实现全网可达、

实验拓扑如图所示:

第一步;

路由器AR1各个接口配置IP,AR2和AR3同理

AR1代码如下:

<AR1>system-view

[Huawei]sysname AR2

[AR1]interface g0/0/0

[AR1-GigabitEthernet0/0/0]ip address 192.168.1.1 24 [AR1-GigabitEthernet0/0/0]q

[AR1]interface g0/0/1

[AR1-GigabitEthernet0/0/1]ip address 192.168.2.1 24

[AR1-GigabitEthernet0/0/1]q

PC1配置对应IP地址、网关以及子网掩码,PC2,PC3同理

图中PC1的网关是PC1连接路由器AR1的接口GE0/0/0的IP地址

第二步:

测试PC1与PC2、PC3的连通性

第三步:

查看AR1、AR2、AR3的路由表,并配置静态路由

AR1的代码如下:

[AR1]display ip routing-table

[AR1]ip route-static 192.168.3.0 24 192.168.2.2

[AR1]ip route-static 192.168.4.0 24 192.168.2.2

[AR1]ip route-static 192.168.5.0 24 192.168.2.2

有两条直连网段192.168.1.0/24、192.168.2.0/24;

添加路由器存在到达目标网络192.168.3.0/24、192.168.4.0/24、192.168.5.0/24的静态路由条目

 

 再次查看路由表可知路由器存在到达目标网络192.168.3.0/24、192.168.4.0/24、192.168.5.0/24的静态路由条目,配置成功。

AR2的代码如下:

[AR2]display ip routing-table

[AR2]ip route-static 192.168.1.0 24 192.168.2.1

[AR2]ip route-static 192.168.5.0 24 192.168.4.2

有三条直连网段192.168.2.0/24、192.168.3.0/24、192.168.4.0/24;

 添加路由器存在到达目标网络192.168.1.0/24、192.168.5.0/24的静态路由条目

 

再次查看路由表可知路由器存在到达目标网络192.168.1.0/24、192.168.5.0/24的静态路由条目,配置成功。 

AR3的代码如下:

[AR3]display ip routing-table

[AR3]ip route-static 192.168.1.0 24 192.168.4.1

[AR3]ip route-static 192.168.2.0 24 192.168.4.1

[AR3]ip route-static 192.168.3.0 24 192.168.4.1

有两条直连网段192.168.4.0/24、192.168.5.0/24;

添加路由器存在到达目标网络192.168.1.0/24、192.168.2.0/24、192.168.3.0/24的静态路由条目

 

再次查看路由表可知路由器存在到达目标网络192.168.1.0/24、192.168.2.0/24、192.168.3.0/24的静态路由条目,配置成功。 

第四步:

再次测试PC1与PC2、PC3的连通性

 

可以发现PC1、PC2、PC3之间可以相互ping通,由此可见实现全网可达。 

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/qq_58187222/article/details/125685309

智能推荐

weblogic12c 设置JAVA_HOME CLASSPATH_weblogic12c报没有定义oracle_home环境变量-程序员宅基地

文章浏览阅读300次。此时不应有 \Java\jdk1.6.0_16\lib。是因为环境变量中设置了JAVA_HOME和CLASSPATH解决方法:网上有人说把环境变量删了就好了,本人觉得那么做不好,可能有的程序还依赖他可以给weblogic单独设置JDK在startWebLogic.cmd中靠前位置加入set JAVA_HOME=E:\OracleWeblogic\jdk..._weblogic12c报没有定义oracle_home环境变量

Spring注解之处理常见的 HTTP 请求

5 种常见的请求类型:GET :请求从服务器获取特定资源。举个例子:GET /users(获取所有学生)POST :在服务器上创建一个新的资源。举个例子:POST /users(创建学生)PUT :更新服务器上的资源(客户端提供更新后的整个资源)。举个例子:PUT /users/12(更新编号为 12 的学生)DELETE :从服务器删除特定的资源。举个例子:DELETE /users/12(删除编号为 12 的学生)PATCH :更新服务器上的资源(客户端提供更改的属性,可以看做作是部分更新),

渗透测试靶场环境搭建

CTF(Capture The Flag)竞赛是网络安全领域的一种竞技活动,旨在测试参与者的网络安全技能。解题模式(Jeopardy):这是最常见的CTF竞赛模式。参赛队伍需要在规定的时间内解决主办方提供的网络安全技术挑战题目。题目类型涵盖逆向工程、漏洞挖掘与利用、Web渗透、密码学、取证、隐写、安全编程等多个方面。解题的数量和正确性将决定参赛队伍的排名和得分。攻防模式(Attack-Defense):在这种模式下,参赛队伍在网络空间中相互攻击和防守。

ansys施加多步载荷_fcum,add-程序员宅基地

文章浏览阅读6k次,点赞2次,收藏16次。1、ansys里面分布加载如何实现?2、静态分析里面分布加载和一次性加载有什么不一样?这里用梁弯曲来测试:首先建立梁的模型;finish/clear/filname,'problem beam'/prep7et,1,beam188 !SECTYPE, 1, BEAM, T, , 0SECOFFSET, CENTSECDATA,45e-3,-53e-3,8e-3,8e-3,0,0,0,0,0,0,0,0mp,ex,1,2e11 !弹性模量mp,prxy,1,0.3 !泊_fcum,add

自己制作智能语音机器人(基于jetson nano)_jetson nano语音识别-程序员宅基地

文章浏览阅读3.1k次,点赞3次,收藏22次。主要采用jetson上编写python代码实现,支持离线语音唤醒、在线语音识别、大模型智能文档、在线语音合成。_jetson nano语音识别

我的世界基岩版BDS服务器搭建与使用_mcbds-程序员宅基地

文章浏览阅读1.5w次,点赞5次,收藏23次。前期需要软件远程SSH控制台软件(本教程使用 Remote Terminal 此为win10商店软件)[点我下载(此软件为Xshell)]支持Sftp的FTP软件(本教程使用 FileZilla)[点我下载]服务端(本教程使用 官方bds服务端)Centos或Ubuntu主机一台 (教程使用 centos7.7)注意事项极力推荐Ubuntu系统,Centos需要另需环境。不支持 Windows Server 2012 及以下版本,要使用 Windows 10 (可行)或者 Windows_mcbds

随便推点

PCL报错“error C2653: “sensor_msgs”: 不是类或命名空间名称”_could not find a sensor_msgs/pointcloud2 type on t-程序员宅基地

文章浏览阅读1.4k次。“error C2653: “sensor_msgs”: 不是类或命名空间名称”出现错误是因为在PCL1.8中将PointCloud2加入了pcl名字空间,sensor_msgs是旧的方式,不再使用。修改方法为:将原代码中报错的的这三行sensor_msgs::PointCloud2 cloud_blob;pcl::io::loadPCDFile ("table_scene_lms400_downsampled.pcd", cloud_blob);pcl::fromROSMsg (cloud_b_could not find a sensor_msgs/pointcloud2 type on topic '/livox/lidar' in bag

javascript的slice()与splice()方法-程序员宅基地

文章浏览阅读37次。(1)数组和String对象都有slice()方法。//Arrayvar list = ['A','B','C','D','DS'];console.log(list.slice(2,4));//截取后还是数组//输出:["C", "D"] //Stringvar str = 'ABCSDASD';console.log(str.slice(2..._删除数组中slice返回值

什么是Base64 编码,Base64 编码有哪些优缺点?_base64编码的优点-程序员宅基地

文章浏览阅读2.6k次。很多朋友在工作中,可能经常会用到Base64编码。Base64编码是网络上很常见的用于8Bit字节码的编码方式之一,那么,大家知道为什么要使用Base64 编码,Base64 编码有哪些优缺点呢?下面,我们一起来研究一下。_base64编码的优点

[ protobuf c++ ] protobuf + vs2013编译安装_protobuf2.5.0 vs-程序员宅基地

文章浏览阅读4k次。1:下载:protobuf 2.5.0压缩文件中包含 protobuf-2.5.0.tar.gz 和protoc-2.5.0-win32.zip,protobuf-2.5.0.tar.gz是protobuf的源文件,protoc-2.5.0-win32.zip是一个protoc.exe应用文件,用于把传输类编译成.h和.cc文件。把 protoc-2.5.0-win32.zip 解压后的..._protobuf2.5.0 vs

从0实现一个操作系统内核之启动篇_gcc 写入系统自启动-程序员宅基地

文章浏览阅读3.1k次。大学的时候学的是软件工程专业,大一的时候才开始接触电脑(学校机房里的),到大二才有了自己的电脑。有了电脑之后,才开始慢慢的学习使用windows操作系统,把玩了一段时间之后,又开始把玩linux。我大概是整个计算机学院第一个使用linux的人了,呵呵。由于在中国linux的市场占有率很低,那时候感觉操作一台跑着linux的计算机是一件很牛X的事情。渐渐的我不再满足于仅仅只会使用操作系统,我要从0编_gcc 写入系统自启动